LCD issues

After running the circulator controller for several days now,  after 4-5 hours, sometimes more, sometimes less the LCD seems to start printing garbage characters.  I have tried several different things to get rid of this but have not done so yet.  My latest attempt to get the program to be stable is to add more delay into the program to allow the LCD more time to work.  After reading the LCD manual it seems that this may be an issue and I will keep my fingers crossed however it appears that this may require a better understanding of the LCD and the programming language requiring a bit more studying.   The Arduino and the program are both running correctly in the background and we are enjoying hot showers, the relays come on and shut off at the correct time, all seems to be working fine with the exception of the LCD display, I have switched out the LCD with another of the same brand and type but I think it must just be getting some bad data and not erasing it.  Any suggestions would be helpful.  Sorry about the picture quality, tough to get a good picture of the display.

Garbled display



Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

w

Connecting to %s